Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Boot the installed system

Boot the installed system 4 years 1 month ago #863

  • Masen
  • Masen's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 5
Thank you for a fantastic LIVE-DVD

my problem is after install. When reboot, I'll get the message insert boot media. I've tried all kinds of things install to reserFS, changed the grub.conf file .... I've checked if my device is listed with the command dmesg. It is!!! I really want to install it on my harddrive. Is there anybody out there_
The administrator has disabled public write access.

Aw: Boot the installed system 4 years 1 month ago #864

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
Hi Masen,

ahh - i think it's a little bug :( - i forgot to remove the grub device.map file.
Check it out:
Boot the DVD, click on Terminal in the panel and type in:
sudo rm /boot/grub/device.map
And then start the harddisk installation.

Joern
The administrator has disabled public write access.

Re: Aw: Boot the installed system 4 years 1 month ago #868

  • Masen
  • Masen's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 5
I deleted the file, now at boot it only waits no message at all. Still something....
Thank you for your help.
The administrator has disabled public write access.

Aw: Re: Aw: Boot the installed system 4 years 1 month ago #870

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
Ok, can you tell me the installation device? ( /dev/sda3 ) for example.
The administrator has disabled public write access.

Re: Aw: Re: Aw: Boot the installed system 4 years 1 month ago #871

  • Masen
  • Masen's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 5
In this case I only have one HD connected! I'm installing on a 16 GB ext4 partition and sda2 is Linux SWAP (512 MB). I'm not very aquinted with GRUB bootloader and the installation script but I don't have any windows installation on the system (the other HDD:s is unplugged or this time I unmounted them), anyway I get the question about windows and toorox order in the OS-choice-list. Excuse my english, I hope my explanation is sufficient.
The administrator has disabled public write access.

Aw: Re: Aw: Re: Aw: Boot the installed system 4 years 1 month ago #874

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
Ok, then try to install the bootloader from grub shell:

Toorox was installed on /dev/sda1. So boot the DVD
and start a terminal - type in:
sudo grub
Now type in:
root (hd0,0)
and then:
setup (hd0)
quit
Shutdown the system and start your installed Toorox from HD.
The administrator has disabled public write access.

Aw: Boot the installed system 4 years 1 month ago #881

  • Masen
  • Masen's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 5
Looked fine in GRUB, rebooted and:

VFS: Cannot open root device "sdc1" or unknown-block (0,0) Please append a correct "root=" boot option; here are the available partitions:
1640 80418240 hdd driver: ide-gd
usb 3-1 new low speed USB device using uhci_hdc and address 2
1641 16779861 hdd1
1642 522112 hdd2

1600 4194302 hdc driver:ide-cdrom
Kernel panic not syncing:VFS:Unable to mount root fs on unknown-block (0,0)
Pid 1, comm: swapper Not tainted 2.6.34 gentoo-r3 #1

Call Trace:............. und zu weiter (I did not write down all the rows I think the problem already is clear?

I will try to find out how to include the "root=" boot option
The administrator has disabled public write access.

Aw: Boot the installed system 4 years 1 month ago #882

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
I will try to find out how to include the "root=" boot option
You will find it in /boot/grub/grub.conf of your installed system.
root=/dev/sda1
You can also add a root (hdx,x) line - for example:
root (hd0,0)
The administrator has disabled public write access.

Re: Aw: Boot the installed system 4 years 4 weeks ago #885

  • Masen
  • Masen's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 5
I just changed it in grub.conf from sdc1 to hdd1. Now its up and running. Thank you very much!!! I just want to clear the fixed devices list because there is my other partitions but they do not exsist.
The administrator has disabled public write access.
  • Page:
  • 1
Time to create page: 0.236 seconds
Powered by Kunena Forum
FaLang translation system by Faboba
   
© 2012 toorox.de | Toorox gehört nicht zu dem Gentoo Projekt. Gentoo ® ist eine eingetragene Marke des Förderverein Gentoo e.V. Andere Warenzeichen sind Eigentum der jeweiligen Rechteinhaber. Bitte senden Sie keine Toorox-spezifischen Probleme oder Fehler an Gentoo Bugzilla! Toorox is not part of the Gentoo project. Gentoo ® is a trademark of the registered association Gentoo e.V. Other trademarks are property of their respective owners. Please do not send Toorox-specific bugs or problems to Gentoo bugzilla!