Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: bash

bash 1 year 11 months ago #1605

  • Gramps
  • Gramps's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 5
Hi, I installed 2012 XFCE to hard disk with English, my problem is, bash is using German.
The administrator has disabled public write access.

bash 1 year 11 months ago #1606

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
Hi Gramps,

type in:
locale
and
cat /etc/env.d/02locale
output should be: "en_US.utf8"
The administrator has disabled public write access.

bash 1 year 11 months ago #1607

  • Gramps
  • Gramps's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 5
Hi Joem, I commented in local.gen did a locale-gen the results

Gramps@Snap ~ $ locale
LANG=en_US.utf8
LC_CTYPE="en_US.utf8"
LC_NUMERIC="en_US.utf8"
LC_TIME="en_US.utf8"
LC_COLLATE="en_US.utf8"
LC_MONETARY="en_US.utf8"
LC_MESSAGES="en_US.utf8"
LC_PAPER="en_US.utf8"
LC_NAME="en_US.utf8"
LC_ADDRESS="en_US.utf8"
LC_TELEPHONE="en_US.utf8"
LC_MEASUREMENT="en_US.utf8"
LC_IDENTIFICATION="en_US.utf8"
LC_ALL=en_US.utf8
Gramps@Snap ~ $ su
Password:
bash: warning: setlocale: LC_ALL: cannot change locale (de_DE.utf8): No such file or directory
Snap Gramps # locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_US.utf8
LC_CTYPE="de_DE.utf8"
LC_NUMERIC="de_DE.utf8"
LC_TIME="de_DE.utf8"
LC_COLLATE="de_DE.utf8"
LC_MONETARY="de_DE.utf8"
LC_MESSAGES="de_DE.utf8"
LC_PAPER="de_DE.utf8"
LC_NAME="de_DE.utf8"
LC_ADDRESS="de_DE.utf8"
LC_TELEPHONE="de_DE.utf8"
LC_MEASUREMENT="de_DE.utf8"
LC_IDENTIFICATION="de_DE.utf8"
LC_ALL=de_DE.utf8
Snap Gramps # cat /etc/e
e2fsck.conf eixrc environment etc-update.conf
eclean/ env.d/ eselect/ exports
Snap Gramps # cat /etc/env.d/02locale
LC_ALL="en_US.utf8"
LANG="en_US.utf8"
The administrator has disabled public write access.

bash 1 year 11 months ago #1608

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
Okay, take a look in /root/.bashrc and change the value from "de_DE.utf8"
to "en_US.utf8". That's it.
The administrator has disabled public write access.

bash 1 year 11 months ago #1609

  • Gramps
  • Gramps's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 5
I forgot I edited make.conf

LINGUAS=" en "
The administrator has disabled public write access.

bash 1 year 11 months ago #1610

  • Gramps
  • Gramps's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 5
and here is what I get after editing .bashrc

Snap ~ # locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_US.utf8
LC_CTYPE="en_USE.utf8"
LC_NUMERIC="en_USE.utf8"
LC_TIME="en_USE.utf8"
LC_COLLATE="en_USE.utf8"
LC_MONETARY="en_USE.utf8"
LC_MESSAGES="en_USE.utf8"
LC_PAPER="en_USE.utf8"
LC_NAME="en_USE.utf8"
LC_ADDRESS="en_USE.utf8"
LC_TELEPHONE="en_USE.utf8"
LC_MEASUREMENT="en_USE.utf8"
LC_IDENTIFICATION="en_USE.utf8"
LC_ALL=en_USE.utf8
Snap ~ # su
bash: warning: setlocale: LC_ALL: cannot change locale (en_USE.utf8)
bash: warning: setlocale: LC_ALL: cannot change locale (en_USE.utf8)
The administrator has disabled public write access.

bash 1 year 11 months ago #1611

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
LC_CTYPE="en_USE.utf8"
must be en_US.utf8 not USE :)
The administrator has disabled public write access.

bash 1 year 11 months ago #1612

  • Gramps
  • Gramps's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 5
Thank you Joern, that solved it
The administrator has disabled public write access.
  • Page:
  • 1
Time to create page: 0.239 seconds
Powered by Kunena Forum
FaLang translation system by Faboba
   
© 2012 toorox.de | Toorox gehört nicht zu dem Gentoo Projekt. Gentoo ® ist eine eingetragene Marke des Förderverein Gentoo e.V. Andere Warenzeichen sind Eigentum der jeweiligen Rechteinhaber. Bitte senden Sie keine Toorox-spezifischen Probleme oder Fehler an Gentoo Bugzilla! Toorox is not part of the Gentoo project. Gentoo ® is a trademark of the registered association Gentoo e.V. Other trademarks are property of their respective owners. Please do not send Toorox-specific bugs or problems to Gentoo bugzilla!