Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: toorox in italien languige

toorox in italien languige 3 years 7 months ago #861

compliments bfor toorox , is best of sabayon
I installed gnome version
I wanted to change the whole system in Italian and 'possible?
if yes, like?
tank :woohoo:
The administrator has disabled public write access.

Aw: toorox in italien languige 3 years 7 months ago #869

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
Hi giorgio.01!

Yes, you can change the language to italian.
Here are the instructions:

Click on Terminal and type in:
sudo su
mcedit /etc/locale.gen
Add the following line at the bottom:
it_IT UTF-8
Hit F10 to save & exit
Then type in:
locale-gen
and:
mcedit /etc/env.d/02locale
Modify the 2 lines into:
LC_ALL="it_IT.utf8"
LANG="it_IT.utf8"
again F10 to save the file and execute:
env-update
Now click on the following link:
l10n.gnome.org/teams/it
And click on the User Interface for GNOME 2.30 (stable).
At the bottom you see the "Download all po files"
Download the file to your desktop and create a new folder
"gnome-it".
Click on the downloaded file and unpack all .po files to the
gnome-it folder.
Open a terminal again and navigate to the folder:
cd Desktop/gnome-it
Translate all .po files into .mo files:
for var in *.po; do tmp=`echo $var | cut -d "." -f1`; msgfmt -cv -o $tmp.mo $var; done
Remove all .po files:
rm *.po
Now they must be stored in /usr/share/locale/it/LC_MESSAGES/:
type in:
cp * /usr/share/locale/it/LC_MESSAGES/
and change the permissions:
cd  /usr/share/locale/it/LC_MESSAGES/
chown root:root *
You have to rename some of the .mo files. Have a look in /usr/share/locale/de/LC_MESSAGES/ and compare the names with the files in /usr/share/locale/it/LC_MESSAGES/ You see a "2.0" in some filenames. For example you have to rename "gnome-desktop.mo" to "gnome-desktop-2.0.mo".

Click on System -> Logout User. You will see the Login-Manager. Now you are able to change the language to italian at the bottom. After login again - make a reboot.

Greetings Joern
The administrator has disabled public write access.

Re: Aw: toorox in italien languige 2 years 8 months ago #1236

  • Hurd
  • Hurd's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 1
hi, for kde needs to be done in the same way or is there another procedure? thanks
The administrator has disabled public write access.

Re: Aw: toorox in italien languige 2 years 8 months ago #1237

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
Hi Hurd,

for KDE you have to set the LINGUAS variable in
/etc/make.conf:
LINGUAS="it"
Then install the package: kde-l10n again.
The administrator has disabled public write access.
  • Page:
  • 1
Time to create page: 0.233 seconds
Powered by Kunena Forum
FaLang translation system by Faboba
   
© 2012 toorox.de | Toorox gehört nicht zu dem Gentoo Projekt. Gentoo ® ist eine eingetragene Marke des Förderverein Gentoo e.V. Andere Warenzeichen sind Eigentum der jeweiligen Rechteinhaber. Bitte senden Sie keine Toorox-spezifischen Probleme oder Fehler an Gentoo Bugzilla! Toorox is not part of the Gentoo project. Gentoo ® is a trademark of the registered association Gentoo e.V. Other trademarks are property of their respective owners. Please do not send Toorox-specific bugs or problems to Gentoo bugzilla!