Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Windowmanager

Windowmanager 5 years 1 month ago #501

N'abend erstmal ;)

Habe mir heute mal die Live DVD runtergeladen und angeschaut und muss sagen, Glückwunsch an den Entwickler zu der gelungenen Distribution.

Habe die letzten Jahre überwiegend mit Slackware gearbeitet und wollte nun mal etwas neues ausprobieren und nicht gleich ein komplettes Gentoo neu kompilieren ;)

Deshalb an dieser stelle die Frage, ob es möglich ist unter Toorox einen WM wie z.B. Fluxbox, Blackbox, Enlightenment etc. zu nutzen, da ich KDE überhaupt nicht mag.

Gruß

Marco
The administrator has disabled public write access.

Aw: Windowmanager 5 years 1 month ago #502

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
Nabend Sunrayshadow und willkommen!
Glückwunsch an den Entwickler zu der gelungenen Distribution
Dankeschön - freut mich, dass es Dir gefällt :)

Einen anderen Windowmanager kannst Du natürlich installieren.
Starte mal: Systemconfig -> Software
und gib den Namen des gewünschten WM in das Suchfeld ein.

Gruß Jörn
The administrator has disabled public write access.

Aw: Windowmanager 4 years 11 months ago #648

  • testa
  • testa's Avatar
  • OFFLINE
  • Junior Boarder
  • Posts: 31
Hallo zusammen,

also ich muss mich auch als >nicht KDE Fan< outen , ich bin einfach XFCE sooo gewohnt und nun wollte ich mal fragen wie das mit einem Umstieg so aussieht- wenn das einfach geht würde ich es doch mal angehen und Toorox zu meinem Arbeitssystem machen - gibt es da einen einfachen Weg oder Einwände ? :unsure:
Sollte ich alte Gewohnheiten über (Mother)Bord werfen und mich doch mit KDE anfreunden, wo doch einige viele Programme in Toorox KDE Libraries benutzen ? :silly:

Grüsse und hoffentlich verbreitet sich Toorox immer mehr. :)

testa
The administrator has disabled public write access.

Aw: Windowmanager 4 years 11 months ago #651

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
Hallo testa,
also ich muss mich auch als >nicht KDE Fan< outen
das ist ja nicht schlimm. Dafür hat man ja die Wahl - und das ist auch gut so! :)
gibt es da einen einfachen Weg
Starte mal Systemconfig -> Software
Dort suche nach "xfce" und dann geh auf das xfce-meta Paket und installiere
es. Damit sollte der komplette XFCE gebaut werden. Falls Extra-Pakete nach der Haupt-Installation nicht installiert sein sollten (ohne grünen Punkt), kannst Du diese
auch noch bauen lassen.
Melde dich nun im KDE ab und der XFCE sollte nun im Login-Manager als neue Session auftauchen.
Sollte ich alte Gewohnheiten über (Mother)Bord werfen und mich doch mit KDE anfreunden, wo doch einige viele Programme in Toorox KDE Libraries benutzen ?
Lass den KDE lieber erst noch drauf. Du wirst ja sehen, welche KDE Programme und Konfigurations Tools unter XFCE von Dir benötigt werden.
The administrator has disabled public write access.

Aw: Windowmanager 4 years 11 months ago #657

  • testa
  • testa's Avatar
  • OFFLINE
  • Junior Boarder
  • Posts: 31
Hallo Joern,

also so weit bin ich gekommenn B) xfce4-meta Installieren>
Meldung:
x11-libs/libXi-1.3 scheint maskiert zu sein.
Soll das Paket und seine Abhängigkeiten demaskiert werden?

dann gehe ich auf ja > Ausführen

Alertbox : Datei oder Verzeichnis nicht gefunden: etc/portage/package.unmask

und so ??? I'm ratlos

Gruß
testa
The administrator has disabled public write access.

Aw: Windowmanager 4 years 11 months ago #658

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
Datei oder Verzeichnis nicht gefunden: etc/portage/package.unmask
Ist ein Fehler im Programm - Die Pfadangabe ist nicht absolut ( / vor etc fehlt ).
Mit der aktuellen Portato Version 0.13.1 wurde er behoben. Um diese zu installieren -
öffne eine Konsole und als root ausführen:
layman -o http://portato.sourceforge.net/layman.xml -f -a portato
emerge portato
Portato neu starten und nun sollte die Installation klappen.

Gruß
The administrator has disabled public write access.

Aw: Windowmanager 4 years 11 months ago #659

  • testa
  • testa's Avatar
  • OFFLINE
  • Junior Boarder
  • Posts: 31
Hallo Joern,

vielen Dank für die Unterstützung, einen kleinen Schritt binn ich weiter aber es klappt noch nicht - ich bekomme folgende Meldungen:

nach dem geklappten Portage emerge :


* IMPORTANT: 4 config files in '/etc' need updating.
* See the CONFIGURATION FILES section of the emerge
* man page to learn how to update config files.

Und bei der XFCE Installation :
..........> Zitat

hecking whether NLS is requested... yes
checking for intltool >= 0.31... found
configure: error: Your intltool is too old. You need intltool 0.31 or later.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/xfce-base/libxfce4util-4.7.0/work/libxfce4util-4.7.0/config.log
* ERROR: xfce-base/libxfce4util-4.7.0 failed:
* econf failed
*
* Call stack:
* ebuild.sh, line 61: Called src_configure
* environment, line 3054: Called xfconf_src_configure
* environment, line 3623: Called econf '--disable-dependency-tracking' '--disable-static' '--disable-debug'
* ebuild.sh, line 551: Called die
* The specific snippet of code:
* die "econf failed"
*
* If you need support, post the output of 'emerge --info =xfce-base/libxfce4util-4.7.0',
* the complete build log and the output of 'emerge -pqv =xfce-base/libxfce4util-4.7.0'.
* The complete build log is located at '/var/tmp/portage/xfce-base/libxfce4util-4.7.0/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/xfce-base/libxfce4util-4.7.0/temp/environment'.
* S: '/var/tmp/portage/xfce-base/libxfce4util-4.7.0/work/libxfce4util-4.7.0'

>>> Failed to emerge xfce-base/libxfce4util-4.7.0, Log file:

>>> '/var/tmp/portage/xfce-base/libxfce4util-4.7.0/temp/build.log'

* Messages for package xfce-base/libxfce4util-4.7.0:

* ERROR: xfce-base/libxfce4util-4.7.0 failed:
* econf failed
*
* Call stack:
* ebuild.sh, line 61: Called src_configure
* environment, line 3054: Called xfconf_src_configure
* environment, line 3623: Called econf '--disable-dependency-tracking' '--disable-static' '--disable-debug'
* ebuild.sh, line 551: Called die
* The specific snippet of code:
* die "econf failed"
*
* If you need support, post the output of 'emerge --info =xfce-base/libxfce4util-4.7.0',
* the complete build log and the output of 'emerge -pqv =xfce-base/libxfce4util-4.7.0'.
* The complete build log is located at '/var/tmp/portage/xfce-base/libxfce4util-4.7.0/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/xfce-base/libxfce4util-4.7.0/temp/environment'.
* S: '/var/tmp/portage/xfce-base/libxfce4util-4.7.0/work/libxfce4util-4.7.0'

Gruß und Danke
The administrator has disabled public write access.

Aw: Windowmanager 4 years 11 months ago #660

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
configure: error: Your intltool is too old. You need intltool 0.31 or later.
Suche nach intltool und installiere die neueste Version.
The administrator has disabled public write access.

Aw: Windowmanager 4 years 11 months ago #661

  • testa
  • testa's Avatar
  • OFFLINE
  • Junior Boarder
  • Posts: 31
hatte ich schon nachgeschaut - ist wohl installiert.
The administrator has disabled public write access.

Aw: Windowmanager 4 years 11 months ago #662

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
Genau - 0.40.6-r1. Komisch, dass er bei Dir meckert? Bei mir läuft die Installation prima durch.
Deinstalliere es mal und danach wieder installieren.
The administrator has disabled public write access.

Aw: Windowmanager 4 years 11 months ago #663

  • testa
  • testa's Avatar
  • OFFLINE
  • Junior Boarder
  • Posts: 31
Tja leider keine Veränderung.

Darf ich dich noch mit 2 anderen Fragen belästigen ??

ich habe auch mal im terminal folgendes ausgeführt :
# emerge --update --ask world

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=media-libs/taglib-1.6.1[-asf,-mp4]".
!!! One of the following packages is required to complete your request:
- media-libs/taglib-1.6.1-r1 (Change USE: -asf -mp4)
(dependency required by "media-sound/amarok-2.2.2" [ebuild])
(dependency required by "world" [argument])


und kann ich das ignorieren ??
* IMPORTANT: 4 config files in '/etc' need updating.

ich habe mal nach gelesen , es dreht sich wenn ich es richtig verstanden habe um updates die zwar vorhanden sind aber nicht empfolen sind - oder??

testa
The administrator has disabled public write access.

Aw: Windowmanager 4 years 11 months ago #664

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
emerge: there are no ebuilds built with USE flags to satisfy ">=media-libs/taglib-1.6.1[-asf,-mp4]".
- Portato starten
- taglib neu installieren
- amarok-utils neu installieren (vorher auf Use List klicken und bei bindist den Haken entfernen
- amarok neu installieren (dort vorher auch den Haken bei bindist entfernen)

Sollte ein Fehler mit dem Paket libXtst auftauchen, dieses auch in der neuesten Version installieren.
Jetzt sollte es mit dem world update klappen.
* IMPORTANT: 4 config files in '/etc' need updating.
Das bedeutet, dass Du schon ein paar Pakete aktualisiert hast und für 4 davon neue Konfigurationsdateien bereit stehen.
Diese lassen sich per:
etc-update
installieren oder auch verwerfen.
Ich empfehle jedem Anfänger Punkt 2:
2) Delete update, keeping original as is

Zu dem XFCE Installationsproblem: Hast du Toorox 32-Bit oder 64-Bit installiert?
Ich habe es nämlich mit dem 64-Bit noch nicht versucht zu installieren.
Was Du auch noch probieren kannst:
Lösche den Inhalt von /usr/portage/distfiles und /var/tmp/portage.
Jetzt nochmal die Installation starten ...
The administrator has disabled public write access.

Aw: Windowmanager 4 years 11 months ago #666

  • testa
  • testa's Avatar
  • OFFLINE
  • Junior Boarder
  • Posts: 31
Ich scheitere am selben Problem, auch wenn ich die 2 Ordnerinhalte gelöscht habe!
checking for intltool >= 0.31...  found
configure: error: Your intltool is too old.  You need intltool 0.31 or later.

ich habe im Anschluss an diese Aktion auch
etc-update

ausgeführt >
~ # etc-update
Scanning Configuration files...
Exiting: Nothing left to do; exiting. :)
The administrator has disabled public write access.

Aw: Windowmanager 4 years 11 months ago #669

  • testa
  • testa's Avatar
  • OFFLINE
  • Junior Boarder
  • Posts: 31
Hallo Joern,

habe das System nochmal aufgesetzt, die selbe Prozedur mit
layman -o http://portato.sourceforge.net/layman.xml -f -a portato
emerge portato
und
- Portato starten
- taglib neu installieren
- amarok-utils neu installieren (vorher auf Use List klicken und bei bindist den Haken entfernen
- amarok neu installieren (dort vorher auch den Haken bei bindist entfernen)

durchlaufen -- jeep nun hat es im Anschluss auch mit Xfce geklappt - wiso weiß ich leider nicht da ich nichts anders gemacht habe.

Ich befasse mich gerade mit dem Getnoo Benutzerhandbuch www.gentoo.org/doc/de/handbook/handbook-x86.xml?full=1#book_part2_chap1

nochmals Danke und Grüsse

testa
The administrator has disabled public write access.
  • Page:
  • 1
Time to create page: 0.371 seconds
Powered by Kunena Forum
FaLang translation system by Faboba
   
© 2012 toorox.de | Toorox gehört nicht zu dem Gentoo Projekt. Gentoo ® ist eine eingetragene Marke des Förderverein Gentoo e.V. Andere Warenzeichen sind Eigentum der jeweiligen Rechteinhaber. Bitte senden Sie keine Toorox-spezifischen Probleme oder Fehler an Gentoo Bugzilla! Toorox is not part of the Gentoo project. Gentoo ® is a trademark of the registered association Gentoo e.V. Other trademarks are property of their respective owners. Please do not send Toorox-specific bugs or problems to Gentoo bugzilla!