Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: update world

update world 2 years 2 months ago #1553

  • none
  • none's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 6
Hallo zusammen, nach dem qlandkartegt jetzt läuft, wollte ich noch mein System updaten mit emerge --update world, dann kommt aber leider:

* IMPORTANT: 3 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

Calculating dependencies -

!!! Problem resolving dependencies for media-libs/sdl-mixer from @selected
... done!

!!! The ebuild selected to satisfy "media-libs/sdl-mixer" has unmet requirements.
- media-libs/sdl-mixer-1.2.12-r1::gentoo USE="(consolekit) flac mad mikmod mp3 (multilib) (policykit) vorbis wav -fluidsynth -midi -mod -modplug -playtools -smpeg -static-libs -timidity"

The following REQUIRED_USE flag constraints are unsatisfied:
mikmod? ( mod )

The above constraints are a subset of the following complete expression:
midi? ( any-of ( timidity fluidsynth ) ) timidity? ( midi ) fluidsynth? ( midi ) mp3? ( any-of ( smpeg mad ) ) smpeg? ( mp3 ) mad? ( mp3 ) mod? ( any-of ( mikmod modplug ) ) mikmod? ( mod ) modplug? ( mod )

(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


wenn ich die USE-Flags setze ändert das leider auch nichts an der Meldung

danke für eure Zeit schon mal im vorraus
The administrator has disabled public write access.

Aw: update world 2 years 2 months ago #1559

  • rolandx1
  • rolandx1's Avatar
  • OFFLINE
  • Expert Boarder
  • Posts: 159
  • Thank you received: 5
das ist meine doku vom letzten mal upgraden, evtl. hilft dir das ja

howto install toorox 01/2012 gnome 32bit

dist-upgrade

eix-sync

edit package.use and add:

media-sound/audacious gtk3 -gtk
media-plugins/audacious-plugins gtk3 -gtk
media-libs/libtheora encode
media-libs/mesa xa
sys-kernel/gentoo-sources symlink

delete:
media-libs/sdl-mixer timidity
media-libs/sdl-mixer mikmod
sys-boot/grub multislot
net-libs/libgadu ssl

edit package.mask:
dev-db/mariadb
=dev-libs/libgcrypt-1.5.0_beta1
=dev-lang/ruby-1.8.7_p357
gnome-extra/gpointing-device-settings
>=sys-boot/grub-1.99-r2
=net-libs/libsoup-2.38.1
=net-libs/libsoup-gnome-2.38.1
=media-libs/babl-0.1.10


edit package.unmask/gnome:
<dev-libs/glib-2.30


emerge -C
ntfs3g
sys-boot/grub-1.99-r2
x11-drivers/xf86-video-sisusb
cinelerra
kino
gimp
libreoffice

emerge ufed genlop htop kmod

edit make.conf
useflags: -via -vmware -sis -gimp

emerge -FvuND world && emerge -vuND world

revdep-rebuild

kernel upgrade
emerge gentoo-sources
cp /usr/src/linux-3.1.6-gentoo/.config /usr/src/linux
make oldconfig
make -j2 && make modules_install
cp arch/i386/boot/bzImage /boot/toorox-3.3.5

edit /boot/grub/menu.lst

edit cflags

emerge -ave system

emerge -ave world

revdep-rebuild

reboot

fstab mountpoints
irc.freenode.net
channel: #calculate #calculate-de
The administrator has disabled public write access.

Re: update world 2 years 2 months ago #1560

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
Hallo none,

als root im Terminal ein:
USE="mikmod -mod" emerge sdl-mixer

wird dir weiterhelfen.

Danach wieder:
emerge --update world

Gruß
The administrator has disabled public write access.

Aw: Re: update world 2 years 2 months ago #1561

  • none
  • none's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 6
hallo Joern,

bei

USE="mikmod -mod" emerge sdl-mixer

kommt folgende Fehlermeldung

Calculating dependencies |

!!! Problem resolving dependencies for media-libs/sdl-mixer
... done!

!!! The ebuild selected to satisfy "sdl-mixer" has unmet requirements.
- media-libs/sdl-mixer-1.2.12-r1::gentoo USE="(consolekit) flac mad mikmod mp3 (multilib) (policykit) vorbis wav -fluidsynth -midi -mod -modplug -playtools -smpeg -static-libs -timidity"

The following REQUIRED_USE flag constraints are unsatisfied:
mikmod? ( mod )

The above constraints are a subset of the following complete expression:
midi? ( any-of ( timidity fluidsynth ) ) timidity? ( midi ) fluidsynth? ( midi ) mp3? ( any-of ( smpeg mad ) ) smpeg? ( mp3 ) mad? ( mp3 ) mod? ( any-of ( mikmod modplug ) ) mikmod? ( mod ) modplug? ( mod )

Die USE Flags sind gesetzt bis auf die in Klammern (warum sind die eigendlich in Klammern?)



Gruss stefan
The administrator has disabled public write access.
  • Page:
  • 1
Time to create page: 0.223 seconds
Powered by Kunena Forum
FaLang translation system by Faboba
   
© 2012 toorox.de | Toorox gehört nicht zu dem Gentoo Projekt. Gentoo ® ist eine eingetragene Marke des Förderverein Gentoo e.V. Andere Warenzeichen sind Eigentum der jeweiligen Rechteinhaber. Bitte senden Sie keine Toorox-spezifischen Probleme oder Fehler an Gentoo Bugzilla! Toorox is not part of the Gentoo project. Gentoo ® is a trademark of the registered association Gentoo e.V. Other trademarks are property of their respective owners. Please do not send Toorox-specific bugs or problems to Gentoo bugzilla!