Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Dependencies & Flags

Dependencies & Flags 2 years 9 months ago #1449

Hello, i need some guidance here what to do, and some clarification of what i have below. Firstly, i assume everything following "!!!The ebuild selected to satisfy...." are all missing dependencies?

Secondly, the REQUIRED_USE flag is gtk OR gtk3 (one or the other)?

Thirdly, i see in using portato there is a "tab" at the bottom left corner "Use list", which i am wondering is how to resolve the flag issue with audacious?

Toorox xxxxxxx # emerge --update --deep --with-bdeps=y world
Calculating dependencies -

!!! Problem resolving dependencies for media-plugins/audacious-plugins from @selected
... done!

!!! The ebuild selected to satisfy "media-plugins/audacious-plugins" has unmet requirements.
- media-plugins/audacious-plugins-3.2::gentoo USE="aac alsa cdda flac gnome gtk gtk3 libnotify mp3 nls oss pulseaudio vorbis -adplug -bs2b -cue -ffmpeg -fluidsynth -ipv6 -jack -lame -libsamplerate -midi -mms -mtp -scrobbler -sid -sndfile -wavpack"

The following REQUIRED_USE flag constraints are unsatisfied:
exactly-one-of ( gtk gtk3 )

(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

I have navigated to /etc/portage/package.use and at the bottom reads thus "#portato update#
media-plugins/audacious-plugins -gtk3 -gtk"

Do i need to edit the package.use file? Remove the hash in front of portato?

Thanks for your time, Steve
The administrator has disabled public write access.

Aw: Dependencies & Flags 2 years 8 months ago #1459

  • rolandx1
  • rolandx1's Avatar
  • OFFLINE
  • Expert Boarder
  • Posts: 159
  • Thank you received: 5
hi,

open /etc/portage/package.use und add
media-sound/audacious gtk3 -gtk
media-plugins/audacious-plugins gtk3 -gtk

cu :)
irc.freenode.net
channel: #calculate #calculate-de
The administrator has disabled public write access.

Re: Aw: Dependencies & Flags 2 years 8 months ago #1460

open /etc/portage/package.use und add
media-sound/audacious gtk3 -gtk
media-plugins/audacious-plugins gtk3 -gtk

:) Done, thank you, but on another issue, would you mind telling me what flags would be set in the profile make.conf for installation of vlc? I have had issues getting a gui, default appears to be set for remote control (command line use). The icon does not turn up in applications either, but of course it wouldn't would it?
Am doing a fresh installation also as i upgraded useing 'webr-sync', preference being for all signed off software, i achieved this through the portage guide in the Gentoo Handbook, there was no argument or error messages so i am assuming it went ok. But, will do another install and upgrade using the recommended method 'eix-rsync' (need to check on that).

Thank you for your reply.
The administrator has disabled public write access.

Aw: Re: Aw: Dependencies & Flags 2 years 8 months ago #1461

  • rolandx1
  • rolandx1's Avatar
  • OFFLINE
  • Expert Boarder
  • Posts: 159
  • Thank you received: 5
i think you need media-video/vlc qt4 in your package.use
irc.freenode.net
channel: #calculate #calculate-de
The administrator has disabled public write access.

Re: Aw: Re: Aw: Dependencies & Flags 2 years 8 months ago #1462

So i take it that all the dependencies 'should' be pulled in upon install of vlc, after editing package.use?

Thanks!
The administrator has disabled public write access.

Re: Aw: Dependencies & Flags 2 years 8 months ago #1463

rolandx1 wrote:
hi,

open /etc/portage/package.use und add
media-sound/audacious gtk3 -gtk
media-plugins/audacious-plugins gtk3 -gtk

cu :)

Question on the use of Flags:
Why not just 'media-plugins/audacious gtk3' & 'media-sound/audacious gtk3
why must there be '-gtk' ??
I understand that it is saying NOT to include, and only one or the other is to be used, is this because it is included in other USE= Flags and would be pulled in when using audacious?
The administrator has disabled public write access.

Aw: Re: Aw: Dependencies & Flags 2 years 8 months ago #1464

  • rolandx1
  • rolandx1's Avatar
  • OFFLINE
  • Expert Boarder
  • Posts: 159
  • Thank you received: 5
because +gtk ist set in make.conf and other programms need it, but audacious not. with package.use you can set use flags for only one programm who need other useflags then "globaluseflags" out of make.conf. excuse my bad english, but i hope you know what i mean :)
irc.freenode.net
channel: #calculate #calculate-de
The administrator has disabled public write access.

Re: Dependencies & Flags 2 years 8 months ago #1465

Hey it's all happening right at this very minute, visually saw the gui being loaded for vlc, i am confident this is going to work nicely! :laugh:

This can be marked as 'solved'

Note: Actually, vlc itself did not install, everything else did, that is because after the second reinstall today, i did not wish to sync again due to the rules, the version of vlc it wanted to pull in could not be found. Tomorrow it will all come together!

Thank you very much for sticking with this rolandx1. You were right with 'media-video/vlc qt4 in your package.use'

The other mistake i made was using 'gedit' for the package.use file, i had not noticed the permissions error nor the recent.xbel error (i do have an eye problem) and need to move my head around, up and down. Though i did go back to the package.use file to verify the change had saved, yet i don't understand this. How can that be?
With the Flag issue with Audacious i used nano, though that would have been the 3rd time in several years, i have got use to using gedit in the past, on other distributions, namely Wolvix, which is now long dead.
I really am quiet naive, not only technically, i have lived a pretty sheltered life, my mum and dad made sure that at bedtime it was total darkness and no sound to be heard. When i got married, in less than three years we had three children, and i couldn't understand why. After the fourth i soon woke up and developed severe head aches at bedtime. Of course the wife often complained and had me at the doctors for tests and so fourth, the Dr put me on medication that caused incredible flatulence, just about bedtime, my wife being a nurse made sure i took my medication, and visual watched me at breakfast until i had swallowed it. Soon she could bear no longer to sleep with me and moved to the spare bedroom, where she remains to this very day!!! :ohmy:

Thanks!
The administrator has disabled public write access.

Re: Dependencies & Flags 2 years 8 months ago #1471

It didn't come together, why?
These flags added to package.use 'media-sound/audacious gtk3 -gtk; media-plugins/audacious-plugins gtk3 -gtk' & 'media-video/vlc qt4'.
Then updated as recomended in the linux newbie section, this process took nearly 12hrs to complete, then ended with 60 config files need to be updated /etc, and 3 user config files need to be updated /usr/share/openvpn/easy-rsa.

So what has gone wrong? All went good running through "without" updating, excluding the install of vlc, due to that version now not being available (vlc 1.1.13), And no config errors. So why has this eventuated with an upgrade? Also i have network issue now (no wireless conectivity), which i gather is related to the config files.
I understand the config files can be edited, but 63 of them? Will this issue arise after each sync?

:(
The administrator has disabled public write access.

Aw: Re: Dependencies & Flags 2 years 8 months ago #1472

  • rolandx1
  • rolandx1's Avatar
  • OFFLINE
  • Expert Boarder
  • Posts: 159
  • Thank you received: 5
nothing went wrong:
etc-update is supposed to be run after merging a new package to see if there are updates to the configuration files. If a new configuration file will override an old one, etc-update will prompt the user
for a decision.

and i think you got a new kernel:

xkcd.com/456/

please paste (paste.pocoo.org/) uname -a and eix gentoo-sources, thx
irc.freenode.net
channel: #calculate #calculate-de
The administrator has disabled public write access.

Re: Aw: Re: Dependencies & Flags 2 years 8 months ago #1474

please paste (paste.pocoo.org/) uname -a and eix gentoo-sources, thx[/quote]

Linux Toorox 3.1.6-gentoo #1 SMP PREEMPT Wed Jan 4 17:48:25 CET 2012 i686 Intel(R) Core(TM) i3 CPU M 350 @ 2.27GHz GenuineIntel GNU/Linux

# eix gentoo-sources
sys-kernel/gentoo-sources
Available versions:
(2.6.32-r29) 2.6.32-r29!b!s
(2.6.32-r39) (~)2.6.32-r39!b!s
(2.6.32-r40) (~)2.6.32-r40!b!s
(2.6.32-r41) (~)2.6.32-r41!b!s
(2.6.39-r3) 2.6.39-r3!b!s
(2.6.39-r4) (~)2.6.39-r4!b!s
(3.0.6) 3.0.6!b!s
(3.0.13) (~)3.0.13!b!s
(3.0.14) (~)3.0.14!b!s
(3.0.15) (~)3.0.15!b!s
(3.1.4) (~)3.1.4!b!s
(3.1.5) (~)3.1.5!b!s
(3.1.6) 3.1.6!b!s
(3.1.7) (~)3.1.7!b!s
(3.1.9) (~)3.1.9!b!s
(3.2.0) (~)3.2.0!b!s
(3.2.0-r1) (~)3.2.0-r1!b!s
(3.2.1) (~)3.2.1!b!s
{build deblob symlink}
Installed versions: 3.1.6(3.1.6)!b!s(01:44:02 AM 12/31/2011)(-build -deblob -symlink)
Homepage: dev.gentoo.org/~mpagano/genpatches
Description: Full sources including the Gentoo patchset for the 3.2 kernel tree
The administrator has disabled public write access.

Re: Dependencies & Flags 2 years 8 months ago #1475

Thanks rolandx1,
So after reading up on updating config files, there are various ways to achieve this, of which 'etc-update' is just one method, is it the best method?

If as a user, i have changed screen resolution; set network settings; changed background; etc, are these changes considered altered config files? What i guess i am asking here is, during an upgrade does the new config files NOT automatically merge with these changes? As stated a couple of posts ago, i lost my wireless ability in the network manager after the upgrade, is it related?

Finally, after a sync, and updating the config files, do i need to again sync after each edit of the package.use file? For example, if i now add 'media-video/vlc qt4'. And, should this be done prior to installing vlc, or does it not matter?
The administrator has disabled public write access.

Aw: Re: Dependencies & Flags 2 years 8 months ago #1476

  • rolandx1
  • rolandx1's Avatar
  • OFFLINE
  • Expert Boarder
  • Posts: 159
  • Thank you received: 5
if a programm got more modern you can do more and more and all these new (standard)settings show/edit etc-update. sometimes you make updates and etc-update say: no important changes, nothing todo.
etc-update "never" update your package.use
and no you dont have to eix-sync after every change in package.use, you ve just edit package.use if you want e special or new useflag for one/a few programs

and last the import thing:
Linux Toorox 3.1.6-gentoo #1 SMP PREEMPT Wed Jan 4 17:48:25 CET 2012 i686 Intel(R) Core(TM) i3 CPU M 350 @ 2.27GHz GenuineIntel GNU/Linux

you are using kernel 3.1.6 but 3.2.1 is up-to-date and i you make emerge -avuND world so your toorox think its already available but you havent compile a new kernel yet. i think you should try to build a new kernel :)
1. edit package.use
sys-kernel/gentoo-sources symlink

2. update your useflags
emerge gentoo-sources

3. check
ls -l /usr/src
does it look like:
paste.pocoo.org/show/9OECIZwvDTz78CigZCEX/

4. copy the kernel.config
cp /usr/src/linux-3.1.6-gentoo/.config /usr/src/linux/

5. update the config
cd /usr/src/linux
make oldconfig

6. compile
make -j3 && make modules_install

7. backup old kernel
mv /boot/vmlinuz /boot/vmlinuz.old

8. kernel + grub
cp arch/i386/boot/bzImage /boot/vmlinuz

reboot and hope all works :)

if not: reinstall and edit your package.mask:
>=sys-kernel/gentoo-sources-3.1.7
adn you never get a kernel-upgrade
irc.freenode.net
channel: #calculate #calculate-de
The administrator has disabled public write access.

Re: Dependencies & Flags 2 years 8 months ago #1480

Thank you!

should try to build a new kernel
1. edit package.use
sys-kernel/gentoo-sources symlink...............so i 'add' this to the package.use?

3. check
ls -l /usr/src
does it look like:
paste.pocoo.org/show/9OECIZwvDTz78CigZCEX/...........if it doesn't, i will edit it so it looks same?


The rest of your steps seem straight forward, when you clarify the above ill give a go! :laugh:
The administrator has disabled public write access.

Aw: Re: Dependencies & Flags 2 years 8 months ago #1481

  • rolandx1
  • rolandx1's Avatar
  • OFFLINE
  • Expert Boarder
  • Posts: 159
  • Thank you received: 5
yes "add"
sys-kernel/gentoo-sources symlink
to package.use
now i hope
ls -l /usr/src
does it look like:
paste.pocoo.org/show/9OECIZwvDTz78CigZCEX/
works ;)
irc.freenode.net
channel: #calculate #calculate-de
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Time to create page: 0.421 seconds
Powered by Kunena Forum
FaLang translation system by Faboba
   
© 2012 toorox.de | Toorox gehört nicht zu dem Gentoo Projekt. Gentoo ® ist eine eingetragene Marke des Förderverein Gentoo e.V. Andere Warenzeichen sind Eigentum der jeweiligen Rechteinhaber. Bitte senden Sie keine Toorox-spezifischen Probleme oder Fehler an Gentoo Bugzilla! Toorox is not part of the Gentoo project. Gentoo ® is a trademark of the registered association Gentoo e.V. Other trademarks are property of their respective owners. Please do not send Toorox-specific bugs or problems to Gentoo bugzilla!