Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: FAT und NTFS Partitionen automatisch einbinden ?!?

FAT und NTFS Partitionen automatisch einbinden ?!? 5 years 9 months ago #42

  • ramwold
  • ramwold's Avatar
  • OFFLINE
  • Junior Boarder
  • Posts: 22
Hallo Jörn,
ich habe Toorox mit Kde 4 installiert. Über "System" kann ich meine FAT32 und NTFS Partitionen einwandfrei einbinden und voll darauf zugreifen. Allerdings muss ich das nach jedem Neustart wieder neu machen - auf Dauer ist das ein klein wenig lästig :unsure:

Gibt es eine Möglichkeit diese Partitionen bereits beim Systemstart automatisch zu mounten?

Im Voraus vielen Dank!!
The administrator has disabled public write access.

Ergänzung NTFS lässt sich gar nicht öffnen..... 5 years 9 months ago #43

  • ramwold
  • ramwold's Avatar
  • OFFLINE
  • Junior Boarder
  • Posts: 22
Hallo,

muss leider mein Posting von vorher berichtigen.
NTFS-Partitionen können zwar gemountet aber nicht geöffnet werden. Es erscheint eine entsprechende Fehlermeldung.

Gibt es auch hier eine Lösung ? :blush:

Danke!
The administrator has disabled public write access.

Aw: Ergänzung NTFS lässt sich gar nicht öffnen..... 5 years 9 months ago #44

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
Hallo ramwold!

Um beide Probleme zu lösen, öffne die Datei:
/etc/fstab
Ich vermute, dass bei Deiner NTFS-Partition die umask Option fehlt? Der Eintrag sollte z.B. so aussehen:

/dev/sda1 /mnt/sda1 ntfs noauto,users,exec,ro,umask=222 0 0

Für die automatische Einbindung beim Booten ändere die "noauto" Option der jeweiligen Partition in "auto". Jetzt die fstab speichern und neu starten.

Gruß Joern
The administrator has disabled public write access.

Leider nur Teilerfolg.......... 5 years 9 months ago #47

  • ramwold
  • ramwold's Avatar
  • OFFLINE
  • Junior Boarder
  • Posts: 22
Danke schon mal für die Hilfe. Ich habe jetzt an der fstab rumgebastelt. Jetzt werden alle FAT und NTFS beim Start gemounte und ich kann drauf zugreifen - aber leider NUR LESEND. Wie kann ich denn als Normaler user auf alle Partitionen voll (lesend und schreibend) zugreifen.

Meine fstab sieht jetzt so aus:

/proc /proc proc defaults 0 0
/sys /sys sysfs noauto 0 0
/dev/fd0 /mnt/floppy auto users,noauto,exec 0 0
/dev/cdrom /mnt/cdrom auto users,noauto,exec,ro 0 0
none /dev/shm tmpfs nodev,nosuid,noexec 0 0
# Added by KNOPPIX
/dev/hdb1 /mnt/hdb1 auto auto,users,exec,ro,umask=0000 0 0
# Added by KNOPPIX
/dev/hdb2 /mnt/hdb2 auto auto,users,exec,ro,umask=222 0 0
# Added by KNOPPIX
/dev/hdb3 /mnt/hdb3 auto auto,users,exec,ro,umask=222 0 0
# Added by KNOPPIX
/dev/hdb4 /mnt/hdb4 auto auto,users,exec,ro,umask=0000 0 0
# Added by KNOPPIX
/dev/sda1 /mnt/sda1 ntfs auto,users,exec,ro,umask=222 0 0
# Added by KNOPPIX
/dev/sda2 none swap sw 0 0
# Added by KNOPPIX
/dev/sda5 /mnt/sda5 ext2 noauto,users,exec 0 0
# Added by KNOPPIX
/dev/sdb5 /mnt/sdb5 auto auto,users,exec,ro,umask=0000 0 0
/dev/sda5 / reiserfs defaults 0 1
The administrator has disabled public write access.

Aw: Leider nur Teilerfolg.......... 5 years 9 months ago #48

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
Du hast bei deinen Partitionen die Option ro (read-only) gesetzt. Bei den NTFS Partitionen ist das auch richtig so - aber die FAT32 Partitionen kannst Du auf rw (read-write) setzen und bei diesen dann umask=000 angeben.
The administrator has disabled public write access.

Aw: FAT und NTFS Partitionen automatisch einbinden ?!? 5 years 9 months ago #50

  • ramwold
  • ramwold's Avatar
  • OFFLINE
  • Junior Boarder
  • Posts: 22
Hallo Jörn,
mit deinen Korrekturen funktioniert es jetzt auf den FAT bestens.
Nur auf die NTFS kann ich immer noch nicht schreiben.
NTFS-3g habe ich bereits nachinstalliert.

Muss ich da noch was konfigurieren oder in der fstab ändern??

DANKE!!!!
The administrator has disabled public write access.

PROBLEM GELÖST 5 years 9 months ago #51

  • ramwold
  • ramwold's Avatar
  • OFFLINE
  • Junior Boarder
  • Posts: 22
Hallo,

konnte das Problem lösen.
Ich habe jetzt NTFS-3g nachinstalliert und meine fstab angepasst.
Ich habe die fstab nochmals kopiert - vieleicht kann jemand das Muster gebrauchen.

Nur als Anregung:
Könntest Du diese Einstellungen evtl. in einer kommenden Version implementieren, so wie es z.B. die UBUNTU-Schiene macht? Ich finde das wäre sehr praktisch, meistens will man doch im Mischsystem auf die Win-Partitionen auch schreiben.

Hier als meine fstab:

# Added by KNOPPIX
/dev/hdb1 /mnt/hdb1 vfat auto,users,exec,rw,umask=000 0 0
# Added by KNOPPIX
/dev/hdb2 /mnt/hdb2 ntfs-3g auto,users,exec,rw,umask=000 0 0
# Added by KNOPPIX
/dev/hdb3 /mnt/hdb3 auto auto,users,exec,rw,umask=000 0 0
# Added by KNOPPIX
/dev/hdb4 /mnt/hdb4 auto auto,users,exec,rw,umask=000 0 0
# Added by KNOPPIX
/dev/sda1 /mnt/sda1 ntfs-3g auto,users,exec,rw,umask=000 0 0
# Added by KNOPPIX
/dev/sda2 none swap sw 0 0
# Added by KNOPPIX
/dev/sda5 /mnt/sda5 ext2 noauto,users,exec 0 0
# Added by KNOPPIX
/dev/sdb5 /mnt/sdb5 auto auto,users,exec,rw,umask=000 0 0
/dev/sda5 / reiserfs defaults 0 1
The administrator has disabled public write access.
  • Page:
  • 1
Time to create page: 0.309 seconds
Powered by Kunena Forum
FaLang translation system by Faboba
   
© 2012 toorox.de | Toorox gehört nicht zu dem Gentoo Projekt. Gentoo ® ist eine eingetragene Marke des Förderverein Gentoo e.V. Andere Warenzeichen sind Eigentum der jeweiligen Rechteinhaber. Bitte senden Sie keine Toorox-spezifischen Probleme oder Fehler an Gentoo Bugzilla! Toorox is not part of the Gentoo project. Gentoo ® is a trademark of the registered association Gentoo e.V. Other trademarks are property of their respective owners. Please do not send Toorox-specific bugs or problems to Gentoo bugzilla!