Welcome, Guest
Username: Password: Remember me

TOPIC: KDE4.4

KDE4.4 4 years 9 months ago #698

  • jolato
  • jolato's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 46
Hi,

Hier ist ein Preview von KDE4.4
maketecheasier.com/kde-4-4-preview/2010/01/18

Wie kann ich dass installieren mit Porthole ? :unsure:
The administrator has disabled public write access.

Aw: KDE4.4 4 years 9 months ago #699

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
Um den RC2 von KDE 4.4 zu installieren musst Du als erstes das kde Overlay hinzufügen:
layman -a kde
Danach müssen die Pakete "freigeschaltet" werden:
cd /etc/portage
mv package.keywords package.keywords.bak
mv package.unmask package.unmask.bak
ln -s /usr/local/portage/layman/kde/Documentation/package.keywords/kde-4.4.keywords package.keywords
ln -s /usr/local/portage/layman/kde/Documentation/package.unmask/kde-4.4 package.unmask
Jetzt noch die offizielle Softwaredatenbank aktualisieren:
emerge --sync
und die neueste rc_version von portage "freischalten":
echo "sys-apps/portage" >> /etc/portage/package.unmask
emerge portage
Damit keine Probleme mit Blockern auftreten, am besten alle KDE Pakete deinstallieren - aber HALT! Der KDE läuft ja noch.
Deswegen ein kleiner Umweg mit dem GNOME:
emerge gnome-session gdm
Jetzt rechts-klick "Abmelden" - "Logout" und im Login-Manager als neue Session den GNOME wählen und neu einloggen.
Nun erledigst Du die letzen Schritte mit dem GNOME.
Löschen aller KDE4 Pakete:
emerge -C @kde-4.3
Danach die Installation von KDE 4.4 RC2 (4.3.95) starten:
emerge kde-meta

Eventuelle Fehlermeldungen:
all ebuilds that could satisfy "xxx" have been masked.
Lösung:
Das Paket "xxx" zu /etc/portage/package.unmask hinzufügen (Beispiel):
net-libs/libmsn
Fehlermeldung:
there are no ebuilds built with USE flags to satisfy "[xxx]".
(Change USE: +xxx)
Lösung:
USE="xxx" emerge ...
Fehlermeldung:
(masked by: missing keyword)
Lösung:
Das Paket zu /etc/portage/package.keywords hinzufügen (Beispiel):
net-libs/libmsn **
** = Alle Architekturen

Gruß Joern
The administrator has disabled public write access.

Re: Aw: KDE4.4 4 years 9 months ago #700

  • jolato
  • jolato's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 46
/usr/bin/layman -a kde

Overlay "kde" does not exist!
The administrator has disabled public write access.

Aw: Re: Aw: KDE4.4 4 years 8 months ago #701

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
layman -S
layman -a kde
The administrator has disabled public write access.

Re: Aw: Re: Aw: KDE4.4 4 years 8 months ago #709

  • jolato
  • jolato's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 46
emerge gnome-session gdm

WARNING: One or more repositories have missing repo_name entries:

/usr/local/portage/layman/ralink/profiles/repo_name

NOTE: Each repo_name entry should be a plain text file containing a
unique name for the repository on the first line.
Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy ">=sys-auth/consolekit-0.4[policykit]".
!!! One of the following packages is required to complete your request:
- sys-auth/consolekit-0.4.1 (Change USE: +policykit)
(dependency required by "sys-auth/polkit-0.96" [ebuild])
(dependency required by "sys-apps/devicekit-power-013" [ebuild])
(dependency required by "gnome-base/gnome-session-2.28.0" [ebuild])
(dependency required by "gnome-session" [argument])
The administrator has disabled public write access.

Aw: Re: Aw: Re: Aw: KDE4.4 4 years 8 months ago #711

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
USE="policykit" emerge gnome-session gdm
The administrator has disabled public write access.

Re:Aw: Re: Aw: Re: Aw: KDE4.4 4 years 8 months ago #715

  • jolato
  • jolato's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 46
Etwas besser aber keine Lösing. Eine "loop" ? :)

USE=">=kde-base/kdelibs-4.4.0[semantic-desktop,-kdeprefix,-aqua]" emerge kde-meta

WARNING: One or more repositories have missing repo_name entries:

/usr/local/portage/layman/ralink/profiles/repo_name

NOTE: Each repo_name entry should be a plain text file containing a
unique name for the repository on the first line.
Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-python/sip:0

('installed', '/', 'dev-python/sip-4.9.3-r1', 'nomerge') pulled in by
>=dev-python/sip-4.7.1 required by ('ebuild', '/', 'kde-base/plasma-workspace-4.4.0', 'merge')

('ebuild', '/', 'dev-python/sip-4.10', 'merge') pulled in by
=dev-python/sip-4.10* required by ('ebuild', '/', 'dev-python/PyQt4-4.7', 'merge')

dev-python/PyQt4:0

('ebuild', '/', 'dev-python/PyQt4-4.7', 'merge') pulled in by
>=dev-python/PyQt4-4.7[dbus,sql,svg,webkit,X] required by ('ebuild', '/', 'kde-base/pykde4-4.4.0', 'merge')

('installed', '/', 'dev-python/PyQt4-4.6.2', 'nomerge') pulled in by
>=dev-python/PyQt4-4.4.0[X] required by ('ebuild', '/', 'kde-base/plasma-workspace-4.4.0', 'merge')
>=dev-python/PyQt4-4.4.4-r1 required by ('ebuild', '/', 'kde-base/marble-4.4.0', 'merge')


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously. You may want to try a larger value of the
--backtrack option, such as --backtrack=30, in order to see if that will
solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.


emerge: there are no ebuilds built with USE flags to satisfy ">=kde-base/kdelibs-4.4.0[semantic-desktop,-kdeprefix,-aqua]".
!!! One of the following packages is required to complete your request:
- kde-base/kdelibs-4.4.0 (Change USE: +semantic-desktop)
(dependency required by "kde-base/kdepim-runtime-4.4.0" [ebuild])
(dependency required by "kde-base/kdepim-meta-4.4.0" [ebuild])
(dependency required by "kde-base/kde-meta-4.4.0" [ebuild])
(dependency required by "kde-meta" [argument])
The administrator has disabled public write access.

Aw: Re:Aw: Re: Aw: Re: Aw: KDE4.4 4 years 8 months ago #716

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
emerge sip PyQt4
The administrator has disabled public write access.

Re: Aw: Re:Aw: Re: Aw: Re: Aw: KDE4.4 4 years 8 months ago #718

  • jolato
  • jolato's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 46
Ich kann leider X nicht mehr einschalten ?:

/usr/bin/xdm does not exist
Error could not start the display manager
The administrator has disabled public write access.

Aw: Re: Aw: Re:Aw: Re: Aw: Re: Aw: KDE4.4 4 years 8 months ago #720

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
mcedit /etc/conf.d/xdm
DISPLAYMANAGER="kdm"
Ändere "kdm" in "gdm" so lange der KDE nicht installiert ist.
Dann ein:
/etc/init.d/xdm restart
ausführen.
The administrator has disabled public write access.

Aw: Re: Aw: Re:Aw: Re: Aw: Re: Aw: KDE4.4 4 years 8 months ago #722

  • jolato
  • jolato's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 46
Danke, jetzt funktioniert es besser.

Meine letzte code war:

emerge sip PyQt4

Wie geht es weiter ?
The administrator has disabled public write access.

Aw: Re: Aw: Re:Aw: Re: Aw: Re: Aw: KDE4.4 4 years 8 months ago #723

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
KDE 4.4.0 wurde veröffentlicht und ist schon im offiziellen Portage-Tree gelistet. Du solltest also gleich diese installieren.
Also:
emerge --sync
Alle KDE 4.3 Pakete löschen:
emerge -C @kde-4.3
und dann die neue KDE Installation starten:
emerge kde-meta
The administrator has disabled public write access.

Aw: Re: Aw: Re:Aw: Re: Aw: Re: Aw: KDE4.4 4 years 8 months ago #732

  • jolato
  • jolato's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 46
emerge -C @kde-4.3 produziert einen fehler:

One or more repositories have missing repo_name entries:
Couldn't find "kde-basex,y,z ... to unmerge
No packages selected for removal by unmerge.


In gdm habe ich sehr geringe Kontrolle über die Fenstern (Bewegung nicht möglich). :(
The administrator has disabled public write access.

Aw: Re: Aw: Re:Aw: Re: Aw: Re: Aw: KDE4.4 4 years 8 months ago #733

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
In gdm habe ich sehr geringe Kontrolle über die Fenstern (Bewegung nicht möglich).
Geh in das GNOME-Menu, starte ein Terminal und tippe ein:
metacity &
emerge -C @kde-4.3 produziert einen fehler
Dann hast Du noch nicht Version 2.2 von portage installiert - ich habe es weiter oben beschrieben.
The administrator has disabled public write access.

Aw: Re: Aw: Re:Aw: Re: Aw: Re: Aw: KDE4.4 4 years 8 months ago #734

  • jolato
  • jolato's Avatar
  • OFFLINE
  • Senior Boarder
  • Posts: 46
metacity ist nicht installiert (/usr/bin, /usr/sbin) oder du musst mir die "pathname" geven; gibt es eine andere window manager ?
The administrator has disabled public write access.
Time to create page: 0.358 seconds
Powered by Kunena Forum
FaLang translation system by Faboba
   
© 2012 toorox.de | Toorox gehört nicht zu dem Gentoo Projekt. Gentoo ® ist eine eingetragene Marke des Förderverein Gentoo e.V. Andere Warenzeichen sind Eigentum der jeweiligen Rechteinhaber. Bitte senden Sie keine Toorox-spezifischen Probleme oder Fehler an Gentoo Bugzilla! Toorox is not part of the Gentoo project. Gentoo ® is a trademark of the registered association Gentoo e.V. Other trademarks are property of their respective owners. Please do not send Toorox-specific bugs or problems to Gentoo bugzilla!