Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: System Update (--update world) hängt.

System Update (--update world) hängt. 5 years 1 month ago #440

  • Gnulle
  • Gnulle's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 19
Folks, ich bin es mal wieder mit einem hängenden Systemupdate.

Nach emerge --update world kriege ich folgende Meldungen:
000004 !!! All ebuilds that could satisfy ">=dev-libs/soprano-2.3.0[dbus]" have been masked.
000005 !!! One of the following masked packages is required to complete your request:
000006 - dev-libs/soprano-2.3.0 (masked by: package.mask)
000007 /usr/portage/profiles/base/package.mask:
000008 # Alex Alexander < Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! > (04 Aug 2009)
000009 # masking kde 4.3 dependencies
000010 # before adding them to tree
000011
000012
000013 For more information, see the MASKED PACKAGES section in the emerge
000014 man page or refer to the Gentoo Handbook.
000015 (dependency required by "kde-base/kdelibs-4.3.0" [ebuild])
000016 (dependency required by "world" [argument])

Nutze Toorox 2009-06 unter KDE 4.2.4. Vermutlich ist das die Vorbereitung auf KDE 4.3. Muß ich mich dann wohl gedulden, oder?

Sorry für die DAU-Frage und Danke für ein paar erläuternde Hinweise
Thomas
The administrator has disabled public write access.

Aw: System Update (--update world) hängt. 5 years 1 month ago #441

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
Hallo Gnulle,

Das Paket "dev-libs/soprano-2.3.0" ist vorerst noch maskiert (gesperrt). Bei neuen Paketen ist das normal. Um maskierte Pakete zu entsperren, schau mal in /etc/portage/package.unmask. Dort sind Textdateien, welche einfach nur die Paketnamen aller freizugebenen Pakete enthalten. Füge "dev-libs/soprano" einfach dort hinzu, indem Du folgendes als root in der Konsole ausführst:
echo dev-libs/soprano >> /etc/portage/package.unmask/kde-deps.keywords
Danach sollte Dein Systemupdate fortfahren.

Gruß Joern
The administrator has disabled public write access.

Aw: System Update (--update world) hängt. 5 years 1 month ago #442

  • Gnulle
  • Gnulle's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 19
Hallo Joern,

danke, hier wird einem doch immer geholfen. :) Ich war jetzt nicht sicher, ob ich da w/ KDE 4.3 noch warten muss.

Werde es in der Mittagspause mal probieren und mich dann melden.

VG Thomas alias Gnulle
The administrator has disabled public write access.

Re:Aw: System Update (--update world) hängt. 5 years 4 weeks ago #443

  • Gnulle
  • Gnulle's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 19
Sorry, bin erst heute dazu gekommen. Das Update auf KDE 4.3 scheint dann doch a weng komplizierter. Ein emrege --update world ergab 'blocked files' noch und noch. Das wird mir dann zu kompliziert :-(

Gibt es irgendwo ein HowTo? Ich habe bei Gentoo nachgeschaut (http:/[url=http:///www.linuxized.com/2009/08/kde-4-3-is-here-quick-gentoo-upgrade-guide/]/www.linuxized.com/2009/08/kde-4-3-is-here-quick-gentoo-upgrade-guide/[/url]), aber da wird mit keywords und Kram nur so um sich geschmissen, keine Chance für mich als Newbie.

Ich weiß, RTFM etc., ich mache es mir zu einfach und blah, aber ich finde Toorox als Distri klasse und frage mich, ob nicht auch andere Anwender dieses Problem haben.

Wäre schön, wenn Ihr mir trotzdem weiterhelfen könnt.

Merci Thomas
The administrator has disabled public write access.

Aw: Re:Aw: System Update (--update world) hängt. 5 years 4 weeks ago #445

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
Hallo Gnulle,

"blocked files" kommen ab und zu mal vor.
Paket1 (bereits installiert) blockt dann Paket2 und Paket2 ist eine Abhängigkeit von dem, was Du gerne installieren möchtest. Deinstalliere Paket1 und der Update
Prozess sollte einen Schritt weiter sein. Noch ein Blocker? Dann die gleiche Prozedur ... Nachdem alle Blocker entfernt sind und das Update erfolgreich durchgelaufen ist, am besten abschließend ein:
revdep-rebuild
in der Konsole als root ausführen. Dieses überprüft Dein System auf unterbrochene
Paket Abhängigkeiten und repariert diese automatisch.

Falls Fehlermeldungen beim Update wegen "masked" oder "keywords" auftreten sollten, musst Du diese Pakete in /etc/portage/package.unmask oder package.keywords eintragen. In diesen Ordnern sind bereits Dateien vorhanen. Füge Deine Pakete dort einfach nach dem gleichen Schema hinzu.
Tipp von mir: Installiere mal folgende Programme: himerge und portato. Mit ihnen kannst Du bequem per Maus-Klick bei einem Update Pakete demaskieren, falls solche Fehler auftauchen sollten. Himerge ist zur Zeit leider nur in Englisch verfügbar - aber sehr umfangreich. Portato spricht auch Deutsch mit Dir. Sind beide gute Alternativen zu Porthole.

Gruß Joern
The administrator has disabled public write access.

Re:Aw: Re:Aw: System Update (--update world) hängt. 5 years 3 weeks ago #449

  • Gnulle
  • Gnulle's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 19
Hallo Joern,

anbei Liste der geblockten Files:
[blocks B ] <x11-libs/qt-xmlpatterns-4.5.2 ("<x11-libs/qt-xmlpatterns-4.5.2" is blocking x11-libs/qt-test-4.5.2, x11-libs/qt-opengl-4.5.2, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-svg-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)
[blocks B ] <x11-libs/qt-assistant-4.5.2 ("<x11-libs/qt-assistant-4.5.2" is blocking x11-libs/qt-test-4.5.2, x11-libs/qt-opengl-4.5.2, x11-libs/qt-dbus-4.5.2, x11-libs/qt-script-4.5.2, x11-libs/qt-gui-4.5.2-r2, x11-libs/qt-svg-4.5.2, x11-libs/qt-qt3support-4.5.2, x11-libs/qt-webkit-4.5.2-r1, x11-libs/qt-core-4.5.2, x11-libs/qt-sql-4.5.2)
[blocks B ] >x11-libs/qt-sql-4.4.2-r9999 (">x11-libs/qt-sql-4.4.2-r9999" is blocking x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1)
[blocks B ] >x11-libs/qt-webkit-4.4.2-r9999 (">x11-libs/qt-webkit-4.4.2-r9999" is blocking x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1)
[blocks B ] >x11-libs/qt-core-4.4.2-r9999 (">x11-libs/qt-core-4.4.2-r9999" is blocking x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1)
[blocks B ] >x11-libs/qt-svg-4.4.2-r9999 (">x11-libs/qt-svg-4.4.2-r9999" is blocking x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1)
[blocks B ] >x11-libs/qt-gui-4.4.2-r9999 (">x11-libs/qt-gui-4.4.2-r9999" is blocking x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1)
[blocks B ] >x11-libs/qt-qt3support-4.4.2-r9999 (">x11-libs/qt-qt3support-4.4.2-r9999" is blocking x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1)
[blocks B ] >x11-libs/qt-opengl-4.4.2-r9999 (">x11-libs/qt-opengl-4.4.2-r9999" is blocking x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1)
[blocks B ] >x11-libs/qt-dbus-4.4.2-r9999 (">x11-libs/qt-dbus-4.4.2-r9999" is blocking x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1)
[blocks B ] >x11-libs/qt-test-4.4.2-r9999 (">x11-libs/qt-test-4.4.2-r9999" is blocking x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1)
[blocks B ] kde-base/libkholidays:4.2 ("kde-base/libkholidays:4.2" is blocking kde-base/kdepimlibs-4.3.0)
[blocks B ] >x11-libs/qt-script-4.4.2-r9999 (">x11-libs/qt-script-4.4.2-r9999" is blocking x11-libs/qt-xmlpatterns-4.4.2, x11-libs/qt-assistant-4.4.2-r1)

Kannst Du mir einen Tip geben, wo ich beim Deinstallieren anfangen sollte? Will ja auf der anderen Seite nix kaputtmachen...

Vielen Dank und Grüße Thomas
The administrator has disabled public write access.

Re:Aw: Re:Aw: System Update (--update world) hängt. 5 years 3 weeks ago #450

  • Gnulle
  • Gnulle's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 19
Hab' jetzt einfach mal mit dem deinstallieren angefangen und alle blocked B-files mit emerge --unmerge qt-xxxx rausgeschmissen.

Das Lustige ist, das die genannten Versionen auf dm System nicht installiert waren, sondern neuere Varianten (also statt 4.4.2 die 4.5.2). Habe alle durchgelöscht und nochmal ein --update world probiert, die Fehlermeldungen bleiben die selben :-(

ratloser Thomas
The administrator has disabled public write access.

Aw: Re:Aw: Re:Aw: System Update (--update world) hängt. 5 years 3 weeks ago #451

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
Hallo Gnulle,

versuch erst alle installierten qt- Pakete zu aktualisieren:
emerge `eix -I --only-names qt-`
Wenn Du sie schon gelöscht hast dann:
emerge qt-core qt-sql qt-dbus qt-script qt-test qt-xmlpatterns qt-gui qt-qt3support qt-webkit qt-opengl qt-svg qt-assistant
Danach das Update erneut starten.

Sind die Blocker jetzt weg?

Gruß Joern
The administrator has disabled public write access.

Aw: Re:Aw: Re:Aw: System Update (--update world) hängt. 5 years 3 weeks ago #455

  • Gnulle
  • Gnulle's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 19
Hallo Joern,

momentan startet KDE gar nicht mehr, das hab' ich jetzt wohl endgültig zerschossen...

Ich werde jetzt komplett neu installieren und es dann nochmal probieren (nach meinem Urlaub).

Ich melde mich dann nochmal und danke Dir für Deine Unterstützung erstmal. Finde ich toll, daß Du Dir da soviel Mühe machst.

VG Thomas alias Gnulle
The administrator has disabled public write access.

Aw: Re:Aw: Re:Aw: System Update (--update world) hängt. 5 years 3 weeks ago #456

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
momentan startet KDE gar nicht mehr, das hab' ich jetzt wohl endgültig zerschossen...
Nein, das hast Du bestimmt nicht. Es ist normal, wenn Du QT deinstallierst, dass der KDE nicht mehr startet. Sobald es wieder installiert ist (emerge qt-core qt-...), läuft er wieder.

Gruß Joern
The administrator has disabled public write access.

Aw: System Update (--update world) hängt. 5 years 5 days ago #473

  • Gnulle
  • Gnulle's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 19
Hallo Joern,

gut erholt aus dem Urlaub zurück starte ich mein Toorox. Und siehe da. Auf einmal startet KDE wieder ?!? Ich habe aber nichts geändert...

Da muß ich mein world update wieder ausprobieren. Nach --sync und --update world bekomme ich wieder ein blocked file.

Es ist app-arch/lzma-utils (warum ich hier das Logfile aus Porthole nicht hereinkopieren kann, weiß der Deibel, hat früher mal funktioniert). Ich habe das gemäß Deinen Anmerkungen gelöscht, dann nochmal gesynct, rebooted und wieder ein emerge --update world versucht.

Wieder motzt er über lzma-utils, obwohl laut porthole die Datei nicht installiert ist.

Was kann ich jetzt noch tun?

Schönes Wochenende und VG
Langsam verzweifelnder Thomas

PS: Habe auch versucht himerge zu emergen. Klappt auch nicht, das Proggie ist zwar lt. Porthole installiert, läßt sich aber weder im KDE-Menü noch über die Suchfunktion finden...
The administrator has disabled public write access.

Aw: System Update (--update world) hängt. 5 years 4 days ago #474

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
Hallo Gnulle,
Wieder motzt er über lzma-utils
Welches Paket blockt lzma-utils denn? "app-arch/lzma-utils is blocking ..."
emerge --unmerge lzma-utils
Dann nochmal versuchen.

PS: Habe auch versucht himerge zu emergen. Klappt auch nicht, das Proggie ist zwar lt. Porthole installiert, läßt sich aber weder im KDE-Menü noch über die Suchfunktion finden...
Füge deinen Usernamen der himerge Gruppe hinzu:
Systemconfig -> Benutzer starten und auf den Reiter "Gruppen" gehen.
Dort auf die Gruppe "himerge" klicken und deinen Usernamen hinzufügen.
Programmstart:
Rechstklick -> Befehl ausführen -> himerge eingeben oder über die Konsole
starten.

Gruß Joern
The administrator has disabled public write access.

Re:Aw: System Update (--update world) hängt. 5 years 1 day ago #475

  • Gnulle
  • Gnulle's Avatar
  • OFFLINE
  • Fresh Boarder
  • Posts: 19
Hallo Jörn,

ok, 2 Schritte weiter:

- himerge läuft
- lzma-utils ist gelöscht und blockiert auch nichts mehr.

Eine --update world ergibt jetzt folgende Meldungen:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/qt-script:4

('ebuild', '/', 'x11-libs/qt-script-4.4.2', 'merge') pulled in by
~x11-libs/qt-script-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge')
~x11-libs/qt-script-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-gui-4.4.2-r3', 'merge')
(and 2 more)

('installed', '/', 'x11-libs/qt-script-4.5.2', 'nomerge') pulled in by
>=x11-libs/qt-script-4.5.1:4 required by ('ebuild', '/', 'kde-base/kdeartwork-colorschemes-4.3.1', 'merge')
>=x11-libs/qt-script-4.5.1:4 required by ('ebuild', '/', 'kde-base/ksquares-4.3.1', 'merge')
>=x11-libs/qt-script-4.5.1:4 required by ('ebuild', '/', 'kde-base/kwallet-4.3.1', 'merge')
(and 254 more)

x11-libs/qt-svg:4

('installed', '/', 'x11-libs/qt-svg-4.5.2', 'nomerge') pulled in by
>=x11-libs/qt-svg-4.5.1:4 required by ('ebuild', '/', 'kde-base/kleopatra-4.3.1', 'merge')
>=x11-libs/qt-svg-4.5.1:4 required by ('ebuild', '/', 'kde-base/step-4.3.1', 'merge')
>=x11-libs/qt-svg-4.5.1:4 required by ('ebuild', '/', 'kde-base/nepomuk-4.3.1', 'merge')
(and 254 more)

('ebuild', '/', 'x11-libs/qt-svg-4.4.2', 'merge') pulled in by
~x11-libs/qt-svg-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge')
(and 3 more)

media-libs/alsa-lib:0

('ebuild', '/', 'media-libs/alsa-lib-1.0.21a', 'merge') pulled in by
>=media-libs/alsa-lib-1.0.21 required by ('ebuild', '/', 'media-sound/alsa-utils-1.0.21', 'merge')
(and 32 more)

('installed', '/', 'media-libs/alsa-lib-1.0.20', 'nomerge') pulled in by
media-libs/alsa-lib[midi] required by ('installed', '/', 'kde-base/kdelibs-4.2.4', 'nomerge')
(and 32 more)

x11-libs/qt-xmlpatterns:4

('ebuild', '/', 'x11-libs/qt-xmlpatterns-4.4.2', 'merge') pulled in by
~x11-libs/qt-xmlpatterns-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge')
(and 2 more)

('installed', '/', 'x11-libs/qt-xmlpatterns-4.5.2', 'nomerge') pulled in by
x11-libs/qt-xmlpatterns required by world
x11-libs/qt-xmlpatterns:4 required by ('installed', '/', 'x11-libs/qtscriptgenerator-0.1.0', 'nomerge')

x11-libs/qt-test:4

('ebuild', '/', 'x11-libs/qt-test-4.4.2', 'merge') pulled in by
~x11-libs/qt-test-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge')
(and 2 more)

('installed', '/', 'x11-libs/qt-test-4.5.2', 'nomerge') pulled in by
>=x11-libs/qt-test-4.5.1:4 required by ('ebuild', '/', 'kde-base/kdepim-kresources-4.3.1', 'merge')
>=x11-libs/qt-test-4.5.1:4 required by ('ebuild', '/', 'kde-base/marble-4.3.1', 'merge')
>=x11-libs/qt-test-4.5.1:4 required by ('ebuild', '/', 'kde-base/mplayerthumbs-4.3.1', 'merge')
(and 253 more)

x11-libs/qt-core:4

('installed', '/', 'x11-libs/qt-core-4.5.2', 'nomerge') pulled in by
>=x11-libs/qt-core-4.5.1:4[qt3support,ssl] required by ('ebuild', '/', 'kde-base/kdm-4.3.1', 'merge')
>=x11-libs/qt-core-4.5.1:4[qt3support,ssl] required by ('ebuild', '/', 'kde-base/kwordquiz-4.3.1', 'merge')
>=x11-libs/qt-core-4.5.1:4[qt3support,ssl] required by ('ebuild', '/', 'kde-base/system-config-printer-kde-4.3.1', 'merge')
(and 271 more)

('ebuild', '/', 'x11-libs/qt-core-4.4.2-r2', 'merge') pulled in by
~x11-libs/qt-core-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-test-4.4.2', 'merge')
~x11-libs/qt-core-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-gui-4.4.2-r3', 'merge')
~x11-libs/qt-core-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-sql-4.4.2-r1', 'merge')
(and 15 more)

x11-libs/qt-assistant:4

('installed', '/', 'x11-libs/qt-assistant-4.5.2', 'nomerge') pulled in by
x11-libs/qt-assistant required by world

('ebuild', '/', 'x11-libs/qt-assistant-4.4.2-r1', 'merge') pulled in by
~x11-libs/qt-assistant-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge')
(and 1 more)

x11-libs/qt-sql:4

('ebuild', '/', 'x11-libs/qt-sql-4.4.2-r1', 'merge') pulled in by
~x11-libs/qt-sql-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-assistant-4.4.2-r1', 'merge')
~x11-libs/qt-sql-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge')
~x11-libs/qt-sql-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-qt3support-4.4.2', 'merge')
(and 2 more)

('installed', '/', 'x11-libs/qt-sql-4.5.2', 'nomerge') pulled in by
>=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('ebuild', '/', 'kde-base/kcminit-4.3.1', 'merge')
>=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('ebuild', '/', 'kde-base/kimagemapeditor-4.3.1', 'merge')
>=x11-libs/qt-sql-4.5.1:4[qt3support] required by ('ebuild', '/', 'kde-base/kdeartwork-kscreensaver-4.3.1', 'merge')
(and 256 more)

x11-libs/qt-dbus:4

('installed', '/', 'x11-libs/qt-dbus-4.5.2', 'nomerge') pulled in by
~x11-libs/qt-dbus-4.5.2[-debug] required by ('installed', '/', 'x11-libs/qt-gui-4.5.2-r2', 'nomerge')
>=x11-libs/qt-dbus-4.5.1:4 required by ('installed', '/', 'dev-python/PyQt4-4.5.4-r4', 'nomerge')
(and 7 more)

('ebuild', '/', 'x11-libs/qt-dbus-4.4.2', 'merge') pulled in by
~x11-libs/qt-dbus-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-gui-4.4.2-r3', 'merge')
~x11-libs/qt-dbus-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge')
(and 7 more)

x11-libs/qt-gui:4

('installed', '/', 'x11-libs/qt-gui-4.5.2-r2', 'nomerge') pulled in by
>=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] required by ('ebuild', '/', 'kde-base/libkdeedu-4.3.1', 'merge')
>=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] required by ('ebuild', '/', 'kde-base/kmahjongg-4.3.1', 'merge')
>=x11-libs/qt-gui-4.5.1:4[accessibility,dbus] required by ('ebuild', '/', 'kde-base/phonon-kde-4.3.1', 'merge')
(and 272 more)

('ebuild', '/', 'x11-libs/qt-gui-4.4.2-r3', 'merge') pulled in by
~x11-libs/qt-gui-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-assistant-4.4.2-r1', 'merge')
~x11-libs/qt-gui-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-core-4.4.2-r2', 'merge')
~x11-libs/qt-gui-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-svg-4.4.2', 'merge')
(and 17 more)

x11-libs/qt-opengl:4

('installed', '/', 'x11-libs/qt-opengl-4.5.2-r1', 'nomerge') pulled in by
>=x11-libs/qt-opengl-4.5.1:4 required by ('ebuild', '/', 'kde-base/kdeartwork-kscreensaver-4.3.1', 'merge')
>=x11-libs/qt-opengl-4.5.1:4 required by ('ebuild', '/', 'kde-base/kdeplasma-addons-4.3.1', 'merge')
>=x11-libs/qt-opengl-4.5.1:4 required by ('ebuild', '/', 'kde-base/kubrick-4.3.1', 'merge')
(and 17 more)

('ebuild', '/', 'x11-libs/qt-opengl-4.4.2', 'merge') pulled in by
~x11-libs/qt-opengl-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge')
(and 3 more)

x11-libs/qt-webkit:4

('installed', '/', 'x11-libs/qt-webkit-4.5.2-r1', 'nomerge') pulled in by
>=x11-libs/qt-webkit-4.5.1:4[kde] required by ('ebuild', '/', 'app-cdr/k3b-1.66.0_alpha2-r1', 'merge')
>=x11-libs/qt-webkit-4.5.1:4 required by ('installed', '/', 'dev-python/PyQt4-4.5.4-r4', 'nomerge')
>=x11-libs/qt-webkit-4.5.1:4[kde] required by ('installed', '/', 'kde-base/kdelibs-4.3.1', 'nomerge')
(and 5 more)

('ebuild', '/', 'x11-libs/qt-webkit-4.4.2-r2', 'merge') pulled in by
~x11-libs/qt-webkit-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-assistant-4.4.2-r1', 'merge')
~x11-libs/qt-webkit-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge')
(and 2 more)

x11-libs/qt-qt3support:4

('ebuild', '/', 'x11-libs/qt-qt3support-4.4.2', 'merge') pulled in by
~x11-libs/qt-qt3support-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-4.4.2', 'merge')
~x11-libs/qt-qt3support-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-gui-4.4.2-r3', 'merge')
(and 1 more)

('installed', '/', 'x11-libs/qt-qt3support-4.5.2', 'nomerge') pulled in by
>=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by ('ebuild', '/', 'kde-base/kmines-4.3.1', 'merge')
>=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by ('ebuild', '/', 'kde-base/kdepim-wizards-4.3.1', 'merge')
>=x11-libs/qt-qt3support-4.5.1:4[accessibility,kde] required by ('ebuild', '/', 'kde-base/libkdepim-4.3.1', 'merge')
(and 252 more)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.

Keine geblockten Files mehr. (freu...)

Wie geht's denn jetzt weiter?

Danke und beste Grüße aus Passau
Thomas alias Gnulle
The administrator has disabled public write access.

Aw: Re:Aw: System Update (--update world) hängt. 5 years 1 day ago #476

  • Joern
  • Joern's Avatar
  • OFFLINE
  • Administrator
  • Posts: 421
  • Thank you received: 5
Okay,

jetzt erst alle qt- Pakete aktualisieren:
emerge `eix -I --only-names qt-`
The administrator has disabled public write access.
  • Page:
  • 1
Time to create page: 0.397 seconds
Powered by Kunena Forum
FaLang translation system by Faboba
   
© 2012 toorox.de | Toorox gehört nicht zu dem Gentoo Projekt. Gentoo ® ist eine eingetragene Marke des Förderverein Gentoo e.V. Andere Warenzeichen sind Eigentum der jeweiligen Rechteinhaber. Bitte senden Sie keine Toorox-spezifischen Probleme oder Fehler an Gentoo Bugzilla! Toorox is not part of the Gentoo project. Gentoo ® is a trademark of the registered association Gentoo e.V. Other trademarks are property of their respective owners. Please do not send Toorox-specific bugs or problems to Gentoo bugzilla!